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The GPS Database Management Package 

 for users of USB ports. 

 

1. Introduction 

 

 This User Manual concentrates on users with units which have USB interfaces, while 

a second copy is aimed at the earlier units. Some models do have both serial and 

USB interfaces, but USB should be preferred where available. 
  

 The GPS models 96C, 296, 396, 496, 696, and Aeras hold a huge amount of 

information in their memory, with up to six types of waypoint, a routes database, a 

track point file, and ‘special use’ airspace information. 

 

 In a typical Aviation Database, there are 50-100,000 different waypoints divided into 

four classes, and covering a selection of countries up to the whole world. There is 

normally ample room for additional information. 

 

 The GPS Database Management Package allows you to archive, list, and make 

changes to all of this data, with a basic set of three easy to use programs and many 

useful utilities.  

 

 

2. Requirements 

 

 A standard PC is required, running at least Windows XP, and up to 100MB of hard 

disc space. 

 

 To make effective use of the Aviation Database section, it is also necessary to have a 

copy of the manufacturer's "Database Update” for one of the above models.  

 

 

3. Overview 

 

 All Garmin Aviation handheld GPS units carry their aviation database, or ‘navdata’, 

in a compiled binary “image” file. No matter what software is used to transfer the 

aviation database from your PC to your GPS, it is an image file which is sent. 

 

 AviaDBM operates on image files, which are given the extension “.img”. Garmin 

uses “.awp” and .taw  files, which are merely image files with a header and a trailer. 

“GEN” programs will strip this header and trailer when given a navdata file, and 
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automatically create a .img file with the same name in the same folder. Any 

operation will do this, such as listing one of the sections. 

 

 GPS_USB sends image files to a GPS unit via a USB port. 

 

 If you want to make any changes to the data in the image file, it has to be completely 

de-compiled into an ISAM database on your PC using the appropriate GEN program. 

Then changes can be made to the ISAM data using GPS_DBM, and a GEN program 

used to make a new image file from this data. 
  

 The package is divided into three distinct sections, each one managed by its own 

program. This is also shewn in diagrammatic form in Appendix ‘A’. 

 

 Please do not forget to read the Technical Notes in section 11 below, the SUA 

Manual, the Release Notes, the FAQs, and the “Known Issues” page on the website, 

all of which are provided to enhance your knowledge of this complex package once 

you have obtained a basic understanding. 

 

 3.1 Communications - GPS_USB 

 

 GPS_USB allows data to be transferred into and out of the GPS via its USB 

interface, and held on the disc drive of the PC in the form of compact binary files. 

 

 You choose the file and direction of transfer, and the program does the rest, keeping 

you informed of its progress. 

 

 With this program alone, you have the ability to take secure re-loadable copies of all 

the data you have keyed into your GPS, and to make hard-copy listings of it. 

 The program places no restriction on the number of GPS units it serves, and will 

upload manufacturer's ".IMG" files even if they have been 'used' previously on a 

different unit. 

 

 Aviation database files with extensions .awp and .taw have to be converted to an 

.img file by using the appropriate _GEN program. This action is a byproduct of any 

operation such as listing one of the sections or creating an ISAM database on the PC. 

 

 GPS_USB can also be used to upload TAWs data direct from suitable .taw files, and 

if your unit supports “VRP Air Sports” you can specify a navdata update file. 

 

 3.2 File Generation - GPS_GEN 

 

 In order to make changes to the aviation database, the package requires that the data 

be transferred from the compact binary .img file into a full relational ISAM database 

on your PC. 
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 The particular program you use depends on the GPS unit you own.  GPS_GEN is for 

96C, 296 and 396, G496_GEN for the 496, and G696_GEN for the 696 and Aera 

models. The program handles the transfer of image data, either into or out of the 

ISAM database, and will be referred to by its generic name GPS_GEN from here on. 

If you are unsure which GEN program to use, GPS_GEN will tell you correct one 

when you try to list an image title. 

 

 GPS_GEN also offers a "Batch" update service for the ISAM database, so that 

collections of previously prepared additions or changes may be re-applied if 

necessary in a fail-safe way. Batch files are plain ASCII text. It is also possible to 

dump as much of the image file as you like into text files in screen format or batch 

format. 

 

 If you would like to add the British Gliding Association database of official turning 

points to your unit, perhaps as NDBs, this batch facility is ideal. A BGA batch is 

supplied with the package. 

 

 Batch changes are fail-safe, in that they may be re-played over and over on the same 

ISAM database without duplication or error, and may also be used on an ISAM 

database generated from a later issue of the manufacturer's ".IMG" file. 

 

 3.3 Database Management - GPS_DBM 

 

 This program allows you to display, select, search for, scroll through, print, and 

make changes to, most parts of the ISAM database. 

 

 Sub-sets of the data may be selected by country and/or identifier. 

 

 All changes you make are also copied, together with their date and time, to a "Batch" 

file, providing an "audit trail" of your actions. There is no need to keep backups of 

the ISAM database, since it can always be re-created from the binary files and this 

Batch file. 

 

 If you make any serious mistakes, the Batch file is easily edited using any text editor 

(such as Notepad), and the situation restored as above. A full description of the 

format used is incorporated in the example Batch file supplied. 

 

 3.4 General Guide to Usage 

 

 This is a summary of the actions normally required to achieve various goals. 

 

3.4.1 Unless you have obtained a .taw or .awp file directly, extract the file from the 

issued .exe file using 7zip. 
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3.4.2 If this file is an aviation database update, GPS_USB mode Write database 

TAWs will upload the ‘VRP Air Sports’ section if available. 

3.4.3 If this file is an aviation database, Create ISAM database on your PC, using 

GPS_GEN and this file. As a side effect of this you will find an image file 

(.img) in the same folder. 

3.4.4 If you do not want to make any changes, this image file can be uploaded 

using GPS_USB mode Write Aviation. 

3.4.5 If you do wish to make changes, use GPS_DBM to perform them on the 

ISAM data, then use GPS_GEN to Create Image from ISAM, and then 

upload this new image. 

3.4.6 This applies only to the APT, INT, NDB, and VOR sections. You can also 

make changes to these sections of the ISAM db using GPS_GEN Perform 

Batch Update together with a text file of changes in batch format. 

3.4.7 The SUA sections use a different method for making changes. They have to 

be saved in text format to a .all file which can be edited then re-compiled 

using GPS_GEN. Please see the SUA Editor’s Manual. 

3.4.8 Finally, if the target unit is not the same type as the update file (as will be the 

case for obsolete units), the Create ISAM operation has to be performed using 

the GPS_GEN program appropriate for the type of update, and the Create 

Image operation using the GPS_GEN program appropriate to the target unit. 

3.4.9 Please also read the Release Notes for more detailed descriptions of recent 

additions, together with the FAQ and Known Errors pages. 

 

 3.5 Benefits 

 

 While it may be desirable to purchase a new manufacturer's database update every 

year (say), there are many simple, but none-the-less irritating, changes occurring 

every month. This package enables you to keep your GPS up to date. 

 

 The BGA turning point database is easily accommodated by the units. The 

recommended method is to enter them as NDBs, with a new 'Country' name "UK 

BGA TP" (say), and a recognizable frequency to set them apart from the real thing, 

130.10 perhaps. On the other hand, you may decide that you do not need NDBs at 

all, and prefer to use this section exclusively for turning points. 

 

 The ability to up and down load data you have keyed into the unit, gives you security 

against its loss from battery failure. You may also keep more than one set of USR 

waypoints and Routes, perhaps for different parts of the world, and make hard-copy 

listings of them. 

 

 If you are like me, you will also perceive great benefit from having complete control 

over a very clever little unit that cost you a lot of money. 
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4. Installation 

 

 The package comes in a self-extracting exe file, which, when run, loads the package 

into a folder of your choice on your hard disk. 

 

 It is probably best if you avoid C:\Program Files and C:\Program Files (x86) if 

changing the installation folder, due to problems for programs which write files into 

the installation folder. 

 

 If you accept the default destination, ‘C:\AviaDBM’, then after installation, your disk 

will contain: 

 

 C:\AviaDBM\bin\GPS_COM.exe 

 C:\AviaDBM\bin\GPS_USB.exe 

 C:\AviaDBM\bin\GPS_SDC.exe 

 C:\AviaDBM\bin\GPS_GEN.exe 

 C:\AviaDBM\bin\G696_GEN..exe 

 C:\AviaDBM\bin\G496_GEN..exe 

 C:\AviaDBM\bin\G3p_GEN..exe 

 C:\AviaDBM\bin\G90_GEN..exe 

 C:\AviaDBM\bin\G92_GEN..exe 

 C:\AviaDBM\bin\G89_GEN..exe 

 C:\AviaDBM\bin\GPS_DBM.exe 

 C:\AviaDBM\bin\GPS_OBS.exe 

 C:\AviaDBM\bin\ConvAir.exe 

 C:\AviaDBM\bin\MapSUA.exe 

 C:\AviaDBM\bin\RemDups.exe 

 C:\AviaDBM\bin\riptaw.exe 

 C:\AviaDBM\bin\FlarmDBM.exe 

 C:\AviaDBM\bin\frq833.pl 

 C:\AviaDBM\bin\AutoGEN.exe 

 C:\AviaDBM\bin\dbview.exe 

 

 C:\AviaDBM\Docs\Introduction.pdf 

 C:\AviaDBM\Docs\Getting Started.pdf 

 C:\AviaDBM\Docs\AviaDBM_FAQ.pdf 

 C:\AviaDBM\Docs\Release Notes.pdf 

 C:\AviaDBM\Docs\UsermanCOM.pdf 

 C:\AviaDBM\Docs\UsermanUSB.pdf 

 C:\AviaDBM\Docs\Appendxa.pdf 

 C:\AviaDBM\Docs\appendxb.pdf 

 C:\AviaDBM\Docs\appendxc.pdf 

 C:\AviaDBM\Docs\appendxd.pdf 

 C:\AviaDBM\Docs\appendxe.pdf 

 C:\AviaDBM\Docs\SUA Manual.pdf 

 C:\AviaDBM\Docs\Imperfections.pdf 
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 C:\AviaDBM\Docs\SUA_Corrupt_Names.pdf 

 C:\AviaDBM\Docs\upd_bat.pdf 

 C:\AviaDBM\Docs\Upd_bat696.pdf 

 C:\AviaDBM\Docs\filenames.pdf 

 C:\AviaDBM\Docs\FLRM_DBM.pdf 

 C:\AviaDBM\Docs\Displaying 8.33khz Channels.pdf 

 C:\AviaDBM\Docs\AeraHowTo.pdf 

 

 C:\AviaDBM\Batches\BGA_TP2020.txt 

 C:\AviaDBM\Batches\Pol_tp.txt 

 C:\AviaDBM\Batches\EU_tpt.txt 

 C:\AviaDBM\Batches\GENcfexample.txt 

 C:\AviaDBM\Batches\DUPcfexample.txt 

 C:\AviaDBM\Batches\UKAirways08.air 

 

 The installation process also creates a Start Menu Folder, with entries for each of the 

programs of the package, and most of the .pdf documents such as the Release Notes 

which everyone should read, this User Manual, and the SUA Editor’s Manual. 

 

5. Getting Started 

 

 These instructions assume that you are familiar with Windows, and are able to use 

Windows Explorer, and Notepad, or their equivalents. You should also be reasonably 

conversant with your GPS unit, particularly the ‘Interface’ page. 

 

 Having installed the software and connected your GPS a USB port, you are ready to 

go. 

 

 We will assume that you placed the package in C:\AviaDBM, so if you chose a 

different directory, please replace “C:\AviaDBM” in the following text. 

 

 To start with, we will transfer your User Waypoints out of the GPS and into a file on 

your PC named “usr.gar” (or “usr.gpx” if you have an Aera) in the C:\AviaDBM 

directory. This will not change what is inside your GPS in any way. 

 

 If you have not created any USR waypoints in your GPS yet, there should be one 

placed there by the manufacturer - the location of his factory. Failing this, please 

create one now - the easiest way is to press AUTO-STORE or Mark, and ENTER 

 

5.1 On the PC, open the AviaDBM5 programs group and run GPS_USB. 

5.2 The program displays the Setup dialog on start-up, already filled in to Read the 

USR database.. 

5.3 If you have an Aera, be sure to click the “Aera Drive” button or fill in the drive 

letter by hand. 
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5.4 Move the cursor to the filename box, and type 'usr.gar' or ‘usr.gpx’ as 

applicable. 

5.5 Click the OK button; a new dialog appears, with 'GO' and 'Cancel' buttons. 

5.6 Read the job description in the main window. 

5.7 Click the GO button; the transfer should start, and progress should be displayed 

on both the PC and the GPS. 

5.8 If the transfer was successful, a “Transfer Complete” message will appear on 

the message page of the GPS. Clear this in the normal way. 

 

If you have an Aera, skip to section 6 below, otherwise you should now have a file 

on your hard disk called C:\AviaDBM\usr.gar. We will now list its contents on 

screen, and print them on the system printer 

 

5.13 If the “Setup Communications” dialog box is not displayed, click the first 

Toolbar button (the Lightning symbol), or choose Setup Comms from the File 

menu. 

 

5.14 Select “List” from the Mode drop-down, and type “usr.gar” in the Filename 

entry box. You can also fill the Filename box by clicking the Browse button 

and using the “Select Binary File” dialog. 

 

5.15 Click OK and GO. The USR waypoints will be displayed, and may be printed 

by clicking the third Toolbar button (the Printer), or choosing Print from the 

File menu. 

 

5.16 You may also view the pages before you print them by choosing Print Preview 

from the File menu, or write them to a plain ASCII file using Save As. 

 

5.17 Exit from the program. 

 

 

6. Making a New Image File 

 

6.1 Most of the package is concerned with the maintenance of  the Aviation 

database, consisting of  APT, INT, NDB, VOR, and optionally SUA, FSS, 

ARTCC, Airway, and Approach sections, together with associated Runways, 

Frequencies, Country and Place Names. 

 

6.2 Since it is not possible to download this database from the GPS unit, you must 

use a manufacturer’s database update file as the source of this information. 

Copy the file (or files) into your C:\AviaDBM folder. Program 7zip will extract 

an .awp file from an .exe file if you downloaded that from his web site. 

 

6.3 Using the appropriate GEN program, from the “Select Required Operation” 

dialog box, which appears when the program is started, choose Create ISAM 
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Database in the Mode drop-down, and enter the full pathname of the image file 

in the Filename box. Alternatively, click the Browse button and find the file 

using the “Select Image File” dialog. 

 

6.4 Click OK, verify the details of the operation in the main window, and click 

GO. The program creates the ISAM database, displaying its progress in the 

form of record counters in the main window. 

 

6.5 When the “Database Complete” message appears, exit from GPS_GEN, and 

run program GPS_DBM. 

 

6.6 The database manager displays the Airports window on start-up. Since you 

have no filters set, the whole database is selected, starting at the first airport. 

Windows are available for simultaneous display of INT, NDB, and VOR 

sections, activated by Toolbar buttons I, N, and V. 

 

6.7 Choose “Filters” from the View menu, and choose your country from the 

Country drop-down list, and click OK. All windows will re-draw to show only 

waypoints with your country code. 

 

6.8 In the Airports Database window, click on one of  the Tower frequency lines. It 

will be highlighted in blue. Now click on the ‘/’ (Change) Toolbar button, or 

choose Chg FRQ from the Edit menu. The “Add or Change a Comms 

Frequency” dialog box appears. 

 

6.9 Make an alteration, and click OK. The highlighted item will be updated. Now 

exit from the program, and run GPS_GEN again. 

 

6.10 Choose “Create Image File from ISAM database” mode, and enter 

“custom.img” in the Filename box. Click OK, confirm your selections in the 

main window, and click GO. The program creates the new image file, 

displaying its progress in the form of record counters. 

 

6.11 When “Image Complete” appears, exit the program. 

 

 

7. Uploading a New Image 

 

7.1 Unless you have an Aera, this operation is irreversible, in the sense that the 

original contents of your GPS unit can only be restored if you have the Image 

file it was loaded from. Aera users will find copies of the navdata and unlock 

files in a new subdirectory ‘AeraBackup’ after the transfer. 

 

7.2 Run program GPS_USB, and choose Write from the Mode list, and Aviation 

from the Database drop-down. Enter the full path name of the image file. 



GPS Database Management  Page 10 2/11/2021 

 

7.3 If your unit is a 96C, 296, 396, or 696, the program first has to upload a 

database 'loader' which it has to obtain from a manufacturer's update file. A 

suitable file (eg: .awp, or .taw) must be located in the same folder as your new 

image. (696 users should seriously consider using GPS_SDC and an SD Card 

to perform updates). 

 

7.4 Click OK, and then GO. The transfer commences, the date and time of 

manufacture of your GPS is displayed (later units employ a hex serial number), 

and the program has to wait while the existing database is erased inside the 

unit. During this waiting period, the message “Waiting for Erase to end” is 

displayed every few seconds. 

 

7.5 During the database upload, a record count is displayed on the screen, and also 

on the Interface page of earlier GPS units. If any proximity points are set, a 

message will be generated to tell you that they have been locked. 

 

7.6 When the transfer is complete, verify its success by switching the GPS unit off 

and then on again, in order to view the title page. (some later units return to 

this page without switching off). 

 

7.7 If a problem occurs, or the transfer stops before completion, reset both 

GPS_USB and the unit, and start the transfer again. 

 

 

8. File Management 

 

 If you have been following the instructions in sections 6 and 7, your 'C:\AviaDBM ' 

directory now contains new files: 

  'usr.gar' or ‘usr.gpx’ created by GPS_USB 

  ‘custom.img’ created by GPS_GEN. 

  ‘upd_bat.txt’ created by GPS_DBM. 

 

 Subdirectory 'DB50' now contains an ISAM database. 

 

 8.1 Binary files 

 

 There are two types of binary file, recognized by their internal data format, and 

carrying the preferred extensions '.img' and '.gar'. The filename parts are your choice. 

Aeras use text files with extension .gpx for waypoints and flight plans. 

 

 Each '.gar' file may hold just one database, chosen from USR waypoints, Routes, 

Proximity points, Track points, or Almanac. Aeras don’t have proximity or almanac. 
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 An '.img' file contains the whole of the Aviation section, that is to say APTs, INTs, 

NDBs, VORs, SUAs, FSS, TCC, Airways, and Approaches, together with ancillary 

information. 

 

 8.2 ISAM Database files 

 

 GPS_GEN and GPS_DBM expect to find the ISAM database in subdirectory 'DB50' 

of the current working directory. If there is no subdirectory ‘DB50’, you are given 

the opportunity to select a DB50 directory anywhere on the system. 

 

 The ISAM database consists of pairs of files having extensions '.dta' (data) and '.dtx' 

(index), and self explanatory names. There is rarely any need to have more than one 

set of these files on your disk, but you can take a copy of them if you wish. 

 

 If any of the database files are absent, both programs will create new empty ones 

when required, so you may remove them in pairs or in groups as you wish. There 

would be no point in deleting the COUNTRY or NAMES files and leaving any 

others, since without Countries and Names, the information in the other files would 

be invalid. Likewise, you should not remove the APTS files without also deleting the 

RWYS, FREQS, and RESTR files. 

 

 You must NOT delete a data file without deleting the index file of the same name.  

 

 You can only transfer data from Binary files into EMPTY (or absent) ISAM database 

files. The Create ISAM operation deletes the whole ISAM database and re-creates it 

from scratch. If you want to remove a whole section, by all means delete its two files 

after create isam. 

 

 If SUA information was available, there will also be a file named ‘sua.dat’, and 

'tcc.dat' if FSS and ARTCC data was present. 

 

 You must not mix database or sua/tcc files which were created from different image 

files, since most of the relational joins are expressed as record numbers. It is also not 

possible to use sua.dat files for a 495/496 with any other unit. 

 

 Only one Image file can be transferred into the ISAM database using Create ISAM. 

If you need to add the data from other Image files, it can be dumped to text files in 

Batch format and input as a Batch Update. AutoGEN can be used to aid in this 

process. 

 

 8.3 Batch Update files 

 

 GPS_DBM opens the file 'upd_bat.txt' in the current working directory 

(C:\AviaDBM), immediately after locating the ISAM database. If the file exists, it is 
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opened, otherwise it is created with zero length. Nothing will be added (save for a 

comment containing today's date) until a change is made to some Aviation data; 

nothing is ever deleted from this file by the package. 

 

 It is a good idea to keep backup copies of this file, since it will contain every change 

you have made to the database. You can edit any mistakes you make using 'Notepad'. 

If you like you can maintain your whole database using Notepad to create a batch 

file, and GPS_GEN to apply it to the ISAM database, without ever using GPS_DBM.  

 

 If you have just completed section 6 above, have a look at upd_bat.txt now. 

 

 

9. Detailed Program Descriptions 

 

 The programs will now be described in detail. In addition to their basic functions, 

they provide many supplementary facilities. In some cases, these facilities are 

duplicated between programs, for instance, you can list most things both direct from 

the image files and out of the ISAM database. Appendix A shows all this in pictorial 

fashion. 

 

 9.1  GPS_USB Communications Program 

 

 9.1.1 Basic Action 

 

 GPS_USB handles the process of moving data in and out of the GPS unit. In the PC, 

all data transferred by GPS_USB is held in the form of compact Binary files, which 

the program recognizes by their internal data format. You should give them 

meaningful names, so you can remember what is in them too; Aviation Binary files 

should have the file extension '.img', while the remainder should be given the 

extension  '.gar'. If you have aviation database files with extensions .awp or .taw you 

must first convert them to a .img file by listing one of the sections using the 

appropriate GPS_GEN program. 

 

 Please note that although 696 units do have a USB interface, transfer of navdata and 

taws files is best performed using GPS_SDC with an SD Card. 

 

 Aera models should be updated by GPS_USB, but their waypoints and routes (flight 

plans) are transferred to/from .gpx files rather than .gar files, and these cannot be 

listed by GPS_USB, although they work normally on import/export by GPS_DBM. 

 

 9.1.2 Setup Dialog 
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 The setup dialog is displayed automatically when you start the program. 

Subsequently you may activate it from the File menu, or from the first Toolbar 

button. If the program is in transfer or listing mode, you may have to select 

STOP/RESET from the File menu, or the second Toolbar button, before Setup is 

available again. 

 

 9.1.3 Modes 

 

 The program offers Read, Write, and List modes in the Mode box. Read mode 

extracts data from the GPS, Write mode transfers data to the GPS, and List mode 

will display the contents of any '.gar' file in scrollable and printable form. 

 

 9.1.4 Databases 

 

 USR, Aviation, Routes, Proximity, Almanac, and Track databases may be chosen in 

the Database box. There are however some illegal combinations of Mode and 

Database, the most obvious being Read Aviation. 

 

 List mode lists the chosen '.gar' file, and does not need to be told what type of data 

that you think the file holds. 

 

 9.1.5 Filenames 

 

 All modes require you to fill in the Filename box. If no path is included with the 

name, then the current working directory is used. If the mode is Read, and the file 

exists, you will be prompted to agree to it being overwritten. 

 

 9.1.6 Browse Button 

 

 The easiest way to fill in the Filename box is to use the Browse button, which 

displays a standard File Dialog. This may be used to select the file, or to select the 

path to a filename which you type in yourself. 

 

 9.1.7 Aera Drive Button 

 

 For an Aera, you must put its drive letter in the Drive box so that the program can 

access it. The drive button should perform this task by searching for your unit. 

 9.1.8 OK Button 
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 When the Startup Dialog is completed to your satisfaction, click on the OK button. If 

there are any problems with your selections, a message box will appear to describe it, 

after which the Startup dialog returns. If all is well, complete details of the intended 

action are displayed in the main window. 

 

 9.1.9 GO Button 

 

 When the Startup dialog details are acceptable, a message box with GO and Cancel 

buttons is displayed. When you click the GO button, the chosen action should 

commence. Transfer times are variable, the worst case being Write TAWs to upload 

a terrain file.  

 

 If you are uploading a .img file to a 96C, 296, 396, or 696 unit, the program will look 

for an .awp file in the same directory. This is because these units require a loader 

program to be uploaded before they can accept the .img file, and this loader is 

located in .awp files. Please ensure that the .awp file, or .taw file if 696, is also for 

your unit type. 

 

 9.1.9 Printing 

 

 The current scrollable contents of the main window can be printed on the system 

printer at any time, by selecting Print from the File menu, or by clicking on the third 

Toolbar button. This is most useful for listing '.gar' files, although the ‘activity log’ 

which accumulates in the main window can also be printed. 

 

 Print Preview is also available in the File menu, giving you an idea of what you will 

get on the printer, and Save As, which writes the output to a plain ASCII file instead 

of the printer. Use File/PrintFont to adjust the character size if necessary. 

 

 9.1.10 General Points 

 

 The Write Aviation Database operation is an 'Erase and Replace' operation, so if you 

interrupt it, you will then have no Aviation data in the unit. This is not a problem, 

because you can simply do it again. You will also get this situation if you try to 

upload an image which is too big for the unit. 

 

 Writing '.gar' or .gpx files on the other hand, is a 'merge' operation. Nothing is 

deleted, and nothing is duplicated, but existing items are updated and new ones 

added. 

 

 If your unit has waypoints from the Aviation section in current Routes - the normal 

situation, then during the Write Aviation operation these waypoints are 'locked'. If 
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the waypoints are not in the new Aviation section, then they remain locked. This is 

not a problem, because you can simply delete or replace them. 

 

 Navdata uploads to an Aera keep copies of the database and its unlock file in a new 

subdirectory to the image folder. 

 

 Due to a manufacturer's omission, it is not possible to up and down load the 'Ref' 

information in a USR waypoint. This field of a USR waypoint will be blank in 

waypoints which have been loaded from the PC. You will also find that the ‘Ref’ 

fields change when a new Aviation database is loaded. This is because they are held 

internally as pointers instead of characters; this is the same for any method of 

database upload. 

 

 GPS_USB has an ini file (GPS_USB.ini) which is created with default values the 

first time the program is used, after which you can make changes which are 

permanent. If you have accepted the default installation folder the ini file will be 

created in the same folder as the executable (C:\AviaDBM\bin). 

 

 

 9.2.  GPS_GEN File Generation Programs 

 

 9.2.1 Basic Functions 

 

 GPS_GEN handles conversions of  ‘.img’ files into entries in the ISAM Database, 

and the creation of ‘.img’ files from ISAM database records. 

 

 The program has up to five other modes, Batch Update, List Image File Sections, 

Compile SUA Text, Compile FSS/TCC Text, and Compile APR Text. Batch Update 

mode applies a Batch of updates to the current ISAM database. You supply the name 

of the Batch file in the filename box, and if you tick the listing box each command is 

listed as it is performed. The operation is fail-safe; the whole file can be re-run if 

necessary, perhaps to incorporate just a few extra changes. 

 

 Listing mode enables you to examine and print an '.img' file section by section. The 

File/SaveAs menu item enables APT, INT, NDB, and VOR listings to be written as 

text files in one of eight different modes. Complete SUA, FSS, TCC, Airways, and 

Approach listings may also be written out in this way. 
  

 9.2.2 Select Database Dialog 

 

 This dialog box only appears if the program cannot find the subdirectory ‘DB50’ in 

the current working directory. Use this standard File Dialog to find a ‘DB50’ 
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directory somewhere on the system. The program will not continue until one is 

found. 

 

 9.2.3 Setup Dialog 

 

 The setup dialog is displayed on program start up; after this, it is available via the 

Setup item in the File menu, or by clicking the first Toolbar button. If the program is 

in Listing mode, you may have to select STOP/RESET from the File menu, or the 

second Toolbar button first. 

 

 The Mode box may be set to 'Create ISAM Database', 'Update ISAM Database', 

'Create Image File', 'List Image File Sections', or 'Compile SUA, FSS/TCC, APR or 

AWY Text'.  

 

 For ISAM Database Creation, the file in the 'Filename' box must exist and be of the 

correct type. For Image File Creation, if the File exists, you will be asked to confirm 

that you want to overwrite it. 

 

 In Update mode, the file must be a plain ASCII file containing update commands, as 

per the issued example files in the Batches subdirectory.  

 

 A 'Browse' button is provided to assist you to complete the 'Filename' box. 

 Listing mode may only be selected for '.img', ‘awp’, or ‘.taw’ files holding navdata. 

If ‘.awp’ or ‘.taw’ is chosen the program first extracts the ‘.img’ file. You choose 

what you wish to list by selecting a section from the “Section” drop-down. If you 

choose the SUA section, in order to create a modifiable text file for re-compilation, 

you should normally have no Filters set, and choose File Type *sua.all. Similarly for 

FSS / TCC sections, which should be placed together in the same file for re-

compilation, and APR sections. 

 

 The 'Filters' button displays the Filters Dialog in the same way as from the View 

menu. The Listing checkbox allows you to inhibit the listing to screen of the input 

lines for the batch and compile functions. 

 

 In Create Image mode, a 'Title' button is available, leading to a dialog box enabling 

you to enter your own title-page identification. The default is CUSTOMISED DB. 

Only the first 20 characters will be used, less on some units. 

 

 Compile SUA Text mode enables you to re-create an 'sua.dat' file from an SUA 

SaveAs ‘.all’ file, normally after making some modifications.  This whole process is 

described fully in the SUA Editor’s Manual. Compile FSS/TCC is similar, but is 

included only to facilitate the creation of world-wide databases, so the co-ordinate 

section is not expanded. 
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 The Approaches data is kept in the ISAM database, and Compile APR is provided to 

allow this data to be updated. Normally this will be from a file previously created 

using SaveAs *apr.all. Airways can similarly be dumped and re-compiled. 

 

 9.2.4 GO Button 

 

 When details of the intended operation have been agreed, a summary is displayed in 

the main window, and a new message box with GO and Cancel buttons appears. 

Click GO to start the operation. 

 

 A limits dialog will be displayed allowing you to impose geographical limits on the 

data being processed. These limits can be entered as "Nddmmss Wdddmmss" (where 

N and W can be S and E, and d=degrees, m=minutes, s=seconds). The format must 

be exactly as stated, and will be used to re-display any entries. Alternatively, they 

may be entered in the form "Ndd~mm.mmm Wddd~mm.mmm". 

 

 If you have chosen Create Database mode, and a database already exists, the 

program will delete it. You may like to archive the files by making copies of them 

before they are deleted. 

 

 Image operations can take some time, during which comprehensive details of 

progress are displayed. As a guide, my old 486-66 takes about 10 minutes to hack 

through a complete '.img' file, so I can imagine some lap-tops taking considerably 

longer. (My Athlon 2400 does it in a flash.) You will see exactly how many items 

there are in each category as the transfer progresses. 

 9.2.5 Optimization 

 

 When creating a '.img' file, the program also optimizes the Names, Runways, and 

Frequencies, by not including unused records. This means that you never need to 

delete runways and frequencies when deleting an airport. The View menu items 

"Optimise" and "Optimise Countries" may be checked/unchecked to vary the default 

actions. Note that if you choose to optimize the countries file you will remove all the 

countries in the half of the world not represented by your database. This will be a 

problem if you have routes in your unit using aviation db waypoints, since the 

country of each waypoint was stored as an index to the countries table, and will most 

probably now be the wrong value. This can be avoided by reading the routes out into 

a .gar file where the countries are held as two-letter idents, and writing it back after 

uploading the new database. 

 

 9.2.6 Accreditation 

 

 It is important that the user of the GPS unit knows that he is using an Aviation 

database that you have modified, particularly since any errors you might make could 
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be blamed on the manufacturer. To this end, the 'title' page is changed to read 

'Customised DB' (although you have the option to set it to anything else), and the 

Cycle Number, Valid From, and Valid To dates are all set to the date that you created 

the '.img' file. For modern units, the copyright notice is changed by replacing the 

manufacturer's name with 'AviaDBM'. 

 

 9.2.7 Section Box 

 

 For Listing mode, the Section box enables you to choose the part of the '.img' file to 

be listed. In addition to the APT, INT, NDB, and VOR sections offered by 

GPS_DBM, you can also list the Countries and Names tables, SUA, FSS, ARTCC, 

Airway, and Approach sections.  

 

 9.2.8 Filters dialog 

 

 This dialog is available from the Filters button of the Setup dialog, or from the View 

menu, and enables you to preset filters for Country, Name, and ICAO Ident in any 

combination. A country filter can only consist of the specific two letter ident for one 

country (the UK would be ‘EG’, Germany ‘ED’, etc), and wildcards are not 

permitted in any filter. The ICAO ident field may also be used to specify a starting 

record number in hexadecimal, by entering the required value preceded by '0X', eg: 

0X23A. 

 

 9.2.9 Printing 

 

 Choose Print from the File menu to print the whole of the scrollable contents of the 

main window. See GPS_DBM for notes on printing, scrolling, and print preview. 

 

 9.2.10 Save As Text 

 

Choose SaveAs from the File menu to dump the whole of the scrollable contents of 

the main window to a text file. There are eight possible modes of operation, 

controlled by the filename used to receive the output, and the country filter. 

 

9.2.10.1 If the letters 'bat' immediately preceded the dot (filename matches 

'*bat.*'), the ouput will be in batch format, otherwise normal text format. 

 

9.2.10.2 If the extension is 'all' (filename matches '*.all'), and one of the four main 

waypoint types is being listed, all four waypoint types will be dumped, 

otherwise only the selected type is output. (This mode is not limited to 

2000 lines like the others). If the current listing is SUAs, and file type 

*sua.all is selected, the whole of the SUA section is output in a form 
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suitable for re-compilation. For FSS or TCC the filename should match 

*tcc.all, and for approaches it should match *apr.all. 

 

9.2.10.3 A country filter may be applied to any output, except where it would be 

meaningless. Note that only APT, INT, NDB, and VOR records carry a 

country identifier. 

 

 9.2.11 Compile SUA 

 

This facility is described in the separate SUA Editor’s Manual. A Compile filters 

dialog box is presented to allow the SUAs to be filtered by applying a maximum 

base altitude (which must be a multiple of 100 feet), and by specifying the South 

West and North East limits of the area required. These co-ordinates must be given 

in degrees, minutes and seconds, Nddmmss for North (or S for South), and 

Edddmmss for East (W for West). 

 

 9.2.12 Compile FSS/TCC 

 

The principal reason for the inclusion of FSS/TCC re-compilation is to enable the 

creation of images using the specified-area method. In particular, the co-ordinate 

sections of the TCC data are not expanded, so modification by hand is not possible. 

 

 9.2.13 Compile APR 

 

This function will read and interpret a text file created in *apr.all format. Unlike the 

other two compile functions, CompileAPR updates the section of the ISAM 

database holding approach data, and remains the only way of making changes to 

this section.  

 

 9.2.14 Control File Operation 

 

For complex operations such as the creation of a whole-world ISAM database, 

followed by the creation of new image files by specifying a geographical area, the 

GEN programs may be operated in Control File mode. This is activated by 

including the name of the control file on the command line preceded by -F. 

Program AutoGEN is provided to make construction of these files easy, and an 

example of the format is provided in file C:\AviaDBM\Batches\GENcfexample.txt. 

 

9.3  GPS_DBM  ISAM Database Management Program 
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 9.3.1 Basic Action 

 

 GPS_DBM allows you to examine, change, and print all the information in the 

ISAM database. Any changes you make are also recorded in the file 'upd_bat.txt' in 

the current working directory. 

 

 A separate window is provided for each of the database types, that is to say, APTs, 

INTs, NDBs, VORs, USR, and RTE. The operations Add, Change, and Delete, are 

provided in all categories. SUA, FSS, and ARTCC information is not kept in the 

ISAM database, and cannot be changed using GPS_DBM. USR and RTE databases 

are imported and exported directly from/to their '*.gar' files using File menu options. 

 

 9.3.2 Select Database Dialog 

 

 This dialog box only appears if the program cannot find the subdirectory ‘DB50’ in 

the current working directory. Use this standard File Dialog to find a ‘DB50’ 

directory somewhere on the system. The program will not continue until one is 

found. 

 

 9.3.3 Choosing the Section 

 

 The APT section is opened at start-up; sections which are not already open can be 

opened by selection in the File menu, or by buttons in the Toolbar labeled A, I, N, V, 

U, R. Windows may be iconized or closed at will, but only one instance of each may 

be active at any time. 

 

 9.3.4 Setting a Filter 

 

 The “Filter Setup” dialog is opened by choosing Filters from the View menu. You 

can reduce the amount of information displayed by setting a Country filter, and/or an 

ICAO ident filter. 

 

 A country filter is set by selecting a country from the Country drop-down list. In 

addition to using the scroll-bar, the list may be scrolled by typing one or more of the 

leading characters of the name.. 

 

 An ident filter is set by entering characters in the ICAO Filter box and may consist of 

one or more characters from the start of the desired set. For instance, a British user 

may enter EG, or perhaps the complete ident of the desired waypoint. 
  

 The program will then display only items which match the characters entered. 
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 Note that these filters are applied to all windows at the same time. Although country 

idents and ICAO idents often use the same letters for airports, this is not the case for 

the other types of waypoint. 

 

 9.3.5 Scrolling Performance 

 

 Most database packages force you to select one item at a time to display and make 

changes to. I decided that a scrollable display of all items was far better. However, 

there are limitations to this approach. 

 

 We are dealing with a massive amount of data here, so there was no way it could be 

held in the PC memory in anything like reasonable chunks*. I therefore decided not 

to hold ANY in memory; every line is displayed directly from disk file. Depending 

on the power of your computer, and the amount of disk caching employed, this will 

be more or less apparent when you search or scroll the display. One line at a time is 

no problem, one page at a time is more serious, and dragging the scroll button up and 

down is really not advisable - I would have disabled it if I'd known how to. 

(Actually, my latest PC can keep up with scroll dragging, and I have also improved 

the performance by generating an in-memory list of record numbers in the 

background. Note the asterisk in the window title bar, and the greyed print 

commands in the File menu during this process). 

 

 Do make use of the Country and ICAO filters, they get you there much more 

quickly. 

 

 Note that due to a library restriction, you cannot have more than about 2000 lines in 

a scrollable window, so if you really do scroll through that many lines, the end may 

be premature - another case for using filters. 

 

 *modern memory capacities do allow whole databases to be held in RAM, but this 

was not the case in the 1990’s when this package was initiated. 

 

 9.3.6 Making Changes 

 

 You can Add a new item in the active window at any time, by selecting Add in the 

Edit menu, or by the '+' button in the Toolbar. 

 An 'Add or Change' dialog is displayed, into which you must put all necessary data. 

 

 To change or delete an item, you must first select it by clicking on an item in the 

window. Then choose Change in the Edit menu, or the '/' Toolbar button to obtain the 

'Add or Change' dialog, and Delete in the Edit menu or the '-' button in the Toolbar to 

obtain the 'Delete' dialog. 
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 Airports have Frequency and Runway sub-sections which may also be selected, 

added to, changed, or deleted. Note however that 'brief' runways (those with zero 

heading displayed as '..-..') can only exist on their own, so any attempt to Add a 

runway in the presence of a 'brief' description will become a Change operation on the 

brief runway. 

 

 Runways also have a 'Picture' field, depicted on the main display as '(p)', and in the 

dialog as runway threshold co-ordinates and bearings. Even if not entering the 

runway picture details,  the bearing is required if the icon is to have its stripe oriented 

correctly. 

 

 9.3.7 Record Numbers 

 

 If the program is called with option ‘-r’, the first column of all listings is the record 

number of that item in the ISAM database. Unless you are really into debugging 

databases, this has little value, save to indicate where changes have been made - you 

get a large and out-of-sequence number for a new record. 

 

 If you are using a low resolution display, you may like to get rid of this column, 

thereby shrinking the width and hopefully getting it on the screen. Choose the 

Record Numbers item in the View menu to toggle these record numbers on and off. 

 

 9.3.8 Printing 

 

 You can print the whole of the data in the active scrollable window, by choosing 

Print from the File menu, or the Print button on the Toolbar. If you have not set any 

filters, back up a truck of paper, and go on holiday for a week. 

 

 Print Preview is also available from the File menu. 

 

 9.3.9 Data Formats 

 

 When filling-in the boxes in the 'Add or Change' dialog, you should enter everything 

in the format used to display these items in the main window. 

 

 All alphabetical characters are converted to upper case, so you can type them in 

lower case if you like. This also applies to Batch files. 

 

 There is a concession with respect to the tilde '~' character which separates the 

degrees portion of a Latitude or Longitude from the minutes part - you may 

substitute a hash '#' or a semicolon ';' if you prefer. 
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 9.3.10 Accuracy 

 

 The GPS unit keeps Latitude and Longitude values which the user enters via the 

keyboard to an accuracy of 26 binary bits. This is roughly equivalent to 0.00016 

minutes of arc, or 6 feet in distance, and far exceeds the accuracy of the unit and any 

of its display modes. 

 

 Latitude and Longitude in the Aviation section are only held to an accuracy of 21 

bits, giving a resolution of 0.00515 minutes, or about 61 feet in distance. The effects 

of this are visible when you examine the Aviation waypoints - they all appear to be 

held to a greater accuracy than is quoted by official sources. The reality is that the 

values were entered with the third decimal place set to zero (say), but on conversion 

to 21 bit binary, they incurred an offset of up to + or - 0.0052 minutes. 

 

 Now that you are able to make your own entries in the Aviation section, you will see 

this inaccuracy at first hand. GPS_DBM makes the conversion at the earliest 

opportunity, so you can if you like influence the final result by adjusting the value 

you enter. 

 

 Co-ordinates in the SUA section are only held in 18 bit resolution, making them a 

further eight times less accurate. Not a real problem since you are never likely to try 

to land on an SUA boundary (unless you are based at our farm strip). 

 

 9.3.11 USR Waypoints 

 

USR Waypoints differ from the AVD sections of the database, in that, apart from the 

batch update facility of GPS_GEN, they are maintained entirely from GPS_DBM.  

 

To read records into the USR section, make USR the active window, and choose 

File/Import to add the waypoints from a '.gar' or ‘.gpx’ format file downloaded by 

GPS_USB. If a waypoint is already present in the ISAM database, it will be updated 

if the imported waypoint carries a later (or zero) date, otherwise all imported 

waypoints are added. File/Clear is also available if you want to start again. 

 

Choose File/Export to create a '.gar' or ‘.gpx’ format file from the current database. 

Support is included at this point for the different waypoint formats employed by 

different  models, making it possible to convert waypoint files from one model to 

another. You can also dump them in Batch File format using File->BatchDump. 

 9.3.12 Routes 

 

To read routes into the RTE section, make Routes the active window, and choose 

File/Import to add the routes from a '.gar' or ‘.gpx’ format file downloaded by 

GPS_USB. If a route is already present in the ISAM database, it will be replaced, 

otherwise all imported routes are added. 



GPS Database Management  Page 24 2/11/2021 

 

All waypoints in an imported route are classed as USR waypoints, but you can 

change this with File/Convert menu option which attempts to change the type of 

waypoint by reference to the current ISAM db. 

 

Adds and Deletes (but not Changes) are allowed for single waypoints or whole 

routes. When adding to a route, any one of the five waypoint types is available - 

provided that the appropriate window is also open. If a waypoint is selected in a 

given window, then details will be copied into the Add Waypoint dialog, making the 

construction of routes a near Drag and Drop operation. 

 

The default Add action is to add a waypoint before the selected one, but this may be 

varied by clicking the 'Add After'  checkbox in the dialog. If the 'Route Number' line 

is selected, then add-after is automatic (Wpt 01 will be added), or for Delete, the 

whole route will be deleted. 

 

To add to an existing route, a waypoint must first be selected in that route. To add 

the first waypoint of a new route, that route number must not exist in the database. 

 

Choose File/Export to create a '.gar' or ‘.gpx’ format file from the current database, 

choosing the appropriate model from the dropdown list. 

 

9.4  GPS_OBS TAWS File Utility 

 9.4.1 Description 

 

GPS_OBS allows Obstacle and AOPA data from .taw files, and VRP data from .awp 

and .taw files to be listed and saved in text format. Obstacle and VRP data can also 

be saved in Batch format for use in units which do not have these facilities. Editing 

and re-compiling is not possible yet, while terrain and safe taxi are not accessible by 

this program. 

 

GPS_OBS dumps obstacles as INTs with idents contrived to indicate the max height 

amsl, while VRPs are dumped as INTs with idents built from their descriptions. In 

both cases, where the generated ident conflicts with an earlier one it is changed by 

altering the final character or characters as necessary. These files are plain text and 

can be edited before applying them to the ISAM database. 

 

 9.4.2 Operation 

 

If you want the data in Batch Format, this should be selected in the View Menu 

before opening a file, because SaveAs will only save the currently displayed data. 
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9.5  ConvAIR Airways Data Conversion Program 

 

 9.5.1 Action 

 

Airways data is normally published by naming the co-ordinates of the start and end 

of the centre line, and specifying the width in nautical miles. To include this data in 

the SUA section it must be converted into the co-ordinates of the four corner points 

of the rectangle, and ConvAIR is provided to perform this task. In addition it handles 

airways which 'dog-leg' by modifying the join to a single line instead of the implied 

overlapping box ends. More detail is included in the SUA Manual. 

 

9.6  RemDups Text File Duplication Removal Program 

 

 9.6.1 Action 

 

RemDups will read one or more text files and look for duplication, then allow the 

user to create a new file without the duplicated sections. For the purposes of 

operating on SUA, FSS, TCC, and APR text dumps, a section is defined as beginning 

with a line having SUA, FSS, TCC, or APR at its start, and continuing until the next 

section start, or the end of file. 

 

 9.6.2 Operation 

 

Select a file to be scanned using the File Open dialog, repeat for as many similar files 

to be included in the whole output file, then write the file with duplicates removed 

using the File SaveAs dialog. This process can take a significant time if there are 

thousands of entries. 

 

 9.6.3 Operation from a Control File 

 

For complex operations such as the creation of a whole-world ISAM database, 

RemDups may be operated in Control File mode. This is activated by including the 

name of the control file on the command line preceded by -F. Program AutoGEN is 

provided to make construction of these files easy, and an example of the format is 

provided in file C:\AviaDBM\Batches\DUPcfexample.txt. 
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9.7  AutoGEN Control File Generation Program 

 9.7.1 Description 

 

AutoGEN is a Console mode program which creates the batch files and associated 

control files required to create a whole-world ISAM database, and create new images 

based on user-defined geographical limits. The name of the subdir to be used is fixed 

at "Auto" (eg: C:\AviaDBM\Auto), and the program expects to be started in 

C:\AviaDBM or one of the subdirs "bin" or "Auto". 

 9.7.2 Operation 

 

Place the necessary .awp files in the Auto subdirectory. Only .awp files which match 

the standard manufacturer's naming convention can be used. Run AutoGEN which 

will create Auto.bat and Control.txt files numbered 1 to 4, then edit the head of 

Control4.txt to preset the required geographical limits of the image to be created. 

Then run each Auto.bat file by double clicking on it. The GEN programs and 

RemDups have been configured to stop when their control file operations are 

completed, leaving the screen log for examination, so they each must be dismissed 

manually before running the next Auto.bat file. 

 

After the first complete cycle, Control4.txt can be re-edited and Auto4.bat re-run if 

different geographical limits are required, or indeed if a different GEN program 

needs to be run. 

 

9.8  RipTaw binary section extraction program 

 9.8.1 Description 

 

Most .taw and .awp files hold more than one binary file, and it is sometimes useful to 

know what they are, and in some cases extract them into separate files. RipTaw will 

do this, using filenames generated from their types and regions. 

 9.8.2 Operation 

 

 The setup dialog allows you to choose the file to be examined, and on clicking OK a 

list of contents is displayed together with a GO dialog. The file extraction does not 

go ahead unless you click the GO button. 
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9.9  GPS_SDC utility 
 

 9.9.1 Description 

 

 The 696, G3X, and G3XT can be updated by SD Card, and this is definitely the 

preferred method, particularly for terrain files. All the required updates can be placed 
on a single card, and the unit will detect the file dates which are later than those 

installed. 

 9.9.2 Model menu 

 

It is essential that the correct model is chosen from the Model menu. 

 9.9.3 Setup Dialog 

 

Boxes are provided for setting the equipment serial number (ESN), the drive letter of 

the SD Card, and the file to be transferred. 

 

The ESN may be entered as a 10 digit decimal value, or a 9 or 13 digit hexadecimal 

value. Some units display both, but the hex value is more reliable as there are some 

G3XT units which do not convert their hex value to decimal correctly.  

 

9.10  dbview utility for the ISAM database 

 9.10.1 Description 

 
The ISAM db on your PC is held in 15 pairs of files in subfolder C:\AviaDBM\db50, 

each pair having extensions .dta (data) and .dtx (index). dbview allows you to view 

the data in these files, but not to make changes. 

 9.10.2 Operation 

 

On startup all 15 of these files appear in their own window displaying their first 

record. Toolbar arrows are provided to move to the next or previous record, or to 

search (N) for a given value in a highlit field. Only some numerical fields can be 

highlit by clicking on them, and if a record cannot be found, the display moves to the 

last record in the file. 
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10. Command Line Options 

 

 A Program Shortcut allows you to specify more than just the name of the program 

that will be run when you double-click its icon. You can also specify the 'current 

working directory' (Start In), and place arguments after the program name. 

 

 If you find that you usually need to set something every time you run a program, 

some of the options can be specified by writing them after the program name, 

separated from it and each other by spaces. 

 

 10.1 GPS_COM Options 

 

-COMn Make COMn the default COM port in the Setup dialog. 

 If 'n' is greater than 4, a new choice is added to the list and selected. 

-AVD  In Host mode, the program identifies itself as a model 95AVD, 

instead of the default model 90. 

-NEWPCL Make the new protocol the default setting. (G3P units only). 

-89  In Host mode, the program identifies itself as a model 89.  

-92  In Host mode, the program identifies itself as a model 92.  

-195  In Host mode, the program identifies itself as a model 195.  

-196  In Host mode, the program identifies itself as a model 196.  

-295  In Host mode, the program identifies itself as a model 295.  

-3P  In Host mode, the program identifies itself as a model III Pilot.  

-d The GPS model identity is displayed at the start of a transfer. 

 

Since the GPS190 and GPS92 use the same image, gps_com treats them alike. 

 

 10.2 GPS_GEN Options 

 

-c XX  Set the listing filter, where XX is a two letter country identifier. 

-n x...  Set the names filter. Names must start with x... 

-i x..  Set the ICAO filter. Idents must start with x.. 

-AVD  Do not use SUA information in Create modes (G90_GEN only). 

-r  Display record numbers. 

-p  Display picture info as hex digits. 

-R  Inhibit optimisation during Create Image File. 

-d  debug. Display more info during Create Image File. 

-f Scan the names table for corrupted terminators on opening an 

image file. (Useful for images dated before Dec 95). 

-F filename Run the program without user intervention by taking all parameters 

from the Control File 'filename'. 
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 10.3 GPS_DBM Options 

 

-c XX  As for GPS_GEN 

-r Display record numbers 

-p Display picture bytes. 

 

11. Technical Notes 

 

11.1 During a ‘Create ISAM Database’ operation, if the image contains SUA data, a 

file ‘SUA.DAT’ is created, and if it contains FSS and ARTCC data, a file 

'TCC.DAT' is created in the ‘DB50’ directory. These are packed binary files 

which cannot be examined by GPS_DBM, and can only be used by GPS_GEN in 

conjunction with the database files created during the same operation. 

 

11.2 It is possible to edit SUA data by using File/SaveAs to dump the whole section to 

a *sua.all file which can be modified using a normal text editor such as Notepad. 

This text file can then be re-compiled by any GEN program and replaced in the 

db50 directory. 

 

11.3 During a 'Create Image' operation, the files SUA.DAT and TCC.DAT are used if 

they are available. Due to changes in record format for G496 units, the pre-

compiled files sua.dat and tcc.dat in folder db50 are not transferable between unit 

types. All the GEN programs recognise and report attempts to use them in the 

wrong unit, so if you want to move their data (say from a 496 to a 296) you must 

Save them as ".all" text files using G496_GEN and re-compile them with 

GPS_GEN. (These operations MUST take place without changing the ISAM 

data). 

 

11.4 The last two letters of some City names, principally in the USA, are the State 

identifier. GPS_GEN and GPS_DBM display these names in the same way as the 

GPS units, with the State code separated from the city name. 

 In order to correctly interpret State codes during additions and changes, an at ‘@’ 

character must be used instead of a space character. GPS_GEN will interpret the 

‘@’ character in a city name in batch update files, and GPS_DBM will insert and 

interpret the character in its Add/Change dialog. 

 

11.5 The Batch Update ADD|RWY description permits values from 00 to 36. Users 

should be aware that values over 18 are stored in the database with 18 subtracted. 

For example, 24L will be stored as 06R. Value 00 is reserved for airports having 

only 'field size' and surface recorded (also referred to as 'brief' airports). 

 

11.6 The package does not perform a range check on frequencies, preferring the less 

restrictive approach of allowing the user to employ out-of-range values for their 

own purposes. The gps image format does impose some limits, however, and 

these are: 
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 APTs - all values 'wrapped' into the range 108.00 to 148.95 

 NDBs - 0 to 32767 ( values > 10,000 have no decimal point) 

 VORs - all values 'wrapped' into the range 108.00 to 120.75 

 

 

11.7 The SUA data of a G496 contains six new zone types, correcting the anomalies 

seen recently in some European zones. Although these new SUA zone types 

cannot be represented by earlier units, I think I have made a better job of mapping 

them onto existing types, and non-496 GEN programs will make these 

conversions if they find them in the data. 

 

11.8 Reports from the Batch Update process consist of a result status in brackets 

followed by the command which was accepted/rejected. These are: 

 

DONE - the item was absent and has been added 

ABS - the airport does not exist (add rwy or frq) 

MODIFIED - the item was present (any differences were noted) 

ERR-NU - item not unique (specify in greater detail) 

ERR-FC - not enough fields 

ERR-F1 - field 1 must be ADD or DEL 

ERR-F2 - field 2 must be APT,INT,NDB,VOR,RWY,FRQ, or USR. 

ERR-F3 - field 3 is too long, or contains illegal characters. 

ERR-CID - (DEL only) Country Ident unknown. 

ERR-CTY - (DEL only) City Name unknown. 

ERR-FAC - (DEL only) Facility Name unknown. 

ERR-LAT - Not N or S, or '~' missing. 

ERR-LNG - Not E or W, or '~' missing. 

ERR-CSP - (ADD only) New Country ID not followed by -name. 

ERR-DME - Optional field in VOR not one of DME, VOR, VORDME,  

   VORTAC, TACAN,  HIGH, LOW, TERM, WX. 

ERR-RWY - Runway description wrong format. 

ERR-LIT - Unknown lighting descriptor. 

ERR-SFC - Unknown surface descriptor. 

ERR-FRQ - Unknown frequency type. 

OK - (Add FRQ only) Item exists as stated. 

INTERNAL ERROR - your guess is as good as mine. 

 

11.9 8.33khz Frequency spacing has created a problem for all units prior to the 696, so 

Garmin has simply chosen to omit these frequencies from their images, even if 

they end with a zero. AviaDBM has a scheme to overcome this problem, 

described in a document included with the distribution. 
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